Arch Linux ETPS/2 Elantech Touchpad

Wie ich ja schon mal geschrieben habe besitze ich seit ein paar Wochen einen Laptop von Acer. Der hat leider ein paar kleine Probleme im Zusammenspiel mit Arch Linux. Doch da Arch Linux eh ein Frickelsystem ist darf ich mich nicht beschweren. Aber nun hab ich immerhin den Trick gefunden das Touchpad zu aktivieren.

Zuerst hab ich den synatics Treiber für X-Server nachinstalliert.

pacman -S xf86-input-synaptics 

Das hat aber nicht dazu geführt, dass das interne Touchpad auch funktioniert. Stattdessen hat es noch ein bisschen Recherche gebraucht.
Im xfce Window Manager unter Einstellungen – Maus und Touchpad werden ja die Geräte angezeigt und mein Touchpad lautet auf den Namen: „ETPS/2 Elantech Touchpad“

Also mit duckduckgo gesucht und folgende Pastebin Seite gefunden und im angegebenen Verzeichnis die Datei erstellt: „/ect/X11/xorg.conf.d/52-elantech-touchpad.conf“ Vielleicht hätte auch /usr/share/ gereicht, aber ich war eh schon im /etc/X11/ Ordner, da hab ich einfach dort die Datei erstellt.

Folgender Inhalt (falls das Internet die verlinkte Seite vergisst!)

    Section "InputClass"
            Identifier "ETPS/2 Elantech Touchpad"
            MatchProduct "ETPS/2 Elantech Touchpad"
            MatchDevicePath "/dev/input/event*"
            Driver "synaptics"
            Option "TapButton1" "1"
            Option "TapButton2" "3"
            Option "TapButton3" "2"
            Option "VertTwoFingerScroll" "1"
            Option "HorizTwoFingerScroll" "1"
            Option "CoastingSpeed" "10"
            Option "EdgeMotionMinZ" "30"
            Option "EdgeMotionMaxZ" "40"
            Option "EdgeMotionMinSpeed" "100"
            Option "EdgeMotionMaxSpeed" "400"
            Option "FingerLow" "9"
            Option "FingerHigh" "12"
            Option "EmulateMidButtonTime" "0"
            Option "ClickPad" "True"
            Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
    EndSection

Nach einem Neustart von Linux funktioniert nun auch endlich das Touchpad. Andere Distributionen hätten es sicherlich eleganter gelöst, aber ich will ja auch was lernen oder zumindest verstehen, was mein System macht.

Nun fehlt nur noch das WLAN. Zumindest mit wifi-menu und der Fritzbox komm ich da nicht weiter. Ist auch ein komischer WLAN Device Name: „wlp13s0“

Falls jemand weiter weiß gerne hier kommentieren. Aber nun mach ich auch wieder Schluss mich auskurieren.